using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"problem path:.+";
string input = @"here is one line
problem path: path1
another line
value line more info
value
problem path: path2
incredible data line
problem path: path3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}