// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)problem path:.+").unwrap();
let string = "here is one line
problem path: path1
another line
value line more info
value
problem path: path2
incredible data line
problem path: path3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}