$re = '/problem path:.+/m';
$str = 'here is one line
problem path: path1
another line
value line more info
value
problem path: path2
incredible data line
problem path: path3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);