re = /problem path:.+/m
str = 'here is one line
problem path: path1
another line
value line more info
value
problem path: path2
incredible data line
problem path: path3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end