# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{5}|[Nn][\/][Aa]/mariano/;t' <<< "marianolkmdwalkm12op3k21op3kplsdkmlkamd"