use strict;
my $str = 'marianolkmdwalkm12op3k21op3kplsdkmlkamd';
my $regex = qr/\d{5}|[Nn][/][Aa]/p;
my $subst = 'mariano';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";