// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{5}|[Nn][/][Aa]").unwrap();
let string = "marianolkmdwalkm12op3k21op3kplsdkmlkamd";
let substitution = "mariano";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}