using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{5}|[Nn][/][Aa]";
string substitution = @"mariano";
string input = @"marianolkmdwalkm12op3k21op3kplsdkmlkamd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}