re = /\d{5}|[Nn][\/][Aa]/
str = 'marianolkmdwalkm12op3k21op3kplsdkmlkamd'
subst = 'mariano'
result = str.sub(re, subst)
# Print the result of the substitution
puts result