const regex = /\d{5}|[Nn][/][Aa]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{5}|[Nn][\/][Aa]', '')
const str = `marianolkmdwalkm12op3k21op3kplsdkmlkamd`;
const subst = `mariano`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);