#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+,\s*\d+(?:\.\d+)?$"
Local $sString = "123,123.4" & @CRLF & _
"1234, 1234" & @CRLF & _
"123, 123.45" & @CRLF & _
"abd, 123" & @CRLF & _
"123, abc" & @CRLF & _
"abc, abc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")