$re = '/^\d+,\s*\d+(?:\.\d+)?$/m';
$str = '123,123.4
1234, 1234
123, 123.45
abd, 123
123, abc
abc, abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);