import re
regex = re.compile(r"^\d+,\s*\d+(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("123,123.4\n"
"1234, 1234\n"
"123, 123.45\n"
"abd, 123\n"
"123, abc\n"
"abc, abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")