re = /^\d+,\s*\d+(?:\.\d+)?$/m
str = '123,123.4
1234, 1234
123, 123.45
abd, 123
123, abc
abc, abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end