// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+,\s*\d+(?:\.\d+)?$").unwrap();
let string = "123,123.4
1234, 1234
123, 123.45
abd, 123
123, abc
abc, abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}