using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+,\s*\d+(?:\.\d+)?$";
string input = @"123,123.4
1234, 1234
123, 123.45
abd, 123
123, abc
abc, abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}