#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w]"
Local $sString = "4852174--r-watch 7 47 2 0 80-B 20 5" & @CRLF & _
"zxcvbnm,.asdfghjkl;'qwertyuiop[]1234567890-=`" & @CRLF & _
"ZXCVN<>?ASDFGHJKL:"QWERTYUIOP{}!@#$%^&*()_+~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")