using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w]";
string input = @"4852174--r-watch 7 47 2 0 80-B 20 5
zxcvbnm,.asdfghjkl;'qwertyuiop[]1234567890-=`
ZXCVN<>?ASDFGHJKL:""QWERTYUIOP{}!@#$%^&*()_+~";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}