import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w]";
final String string = "4852174--r-watch 7 47 2 0 80-B 20 5\n"
+ "zxcvbnm,.asdfghjkl;'qwertyuiop[]1234567890-=`\n"
+ "ZXCVN<>?ASDFGHJKL:\"QWERTYUIOP{}!@#$%^&*()_+~";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}