import re
regex = re.compile(r"[\w]")
test_str = ("4852174--r-watch 7 47 2 0 80-B 20 5\n"
"zxcvbnm,.asdfghjkl;'qwertyuiop[]1234567890-=`\n"
"ZXCVN<>?ASDFGHJKL:\"QWERTYUIOP{}!@#$%^&*()_+~")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")