const regex = new RegExp('[\\w]', 'g')
const str = `4852174--r-watch 7 47 2 0 80-B 20 5
zxcvbnm,.asdfghjkl;'qwertyuiop[]1234567890-=\`
ZXCVN<>?ASDFGHJKL:"QWERTYUIOP{}!@#\$%^&*()_+~`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}