$re = '/[\w]/';
$str = '4852174--r-watch 7 47 2 0 80-B 20 5
zxcvbnm,.asdfghjkl;\'qwertyuiop[]1234567890-=`
ZXCVN<>?ASDFGHJKL:"QWERTYUIOP{}!@#$%^&*()_+~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);