// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w]").unwrap();
let string = "4852174--r-watch 7 47 2 0 80-B 20 5
zxcvbnm,.asdfghjkl;'qwertyuiop[]1234567890-=`
ZXCVN<>?ASDFGHJKL:\"QWERTYUIOP{}!@#$%^&*()_+~";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}