re = /[\w]/
str = '4852174--r-watch 7 47 2 0 80-B 20 5
zxcvbnm,.asdfghjkl;\'qwertyuiop[]1234567890-=`
ZXCVN<>?ASDFGHJKL:"QWERTYUIOP{}!@#$%^&*()_+~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end