# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(value)(\d+)/$2:$1/gm;t' <<< "LeaveThisInArray
value1
value2"