const regex = /^(value)(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(value)(\\d+)', 'gm')
const str = `LeaveThisInArray
value1
value2`;
const subst = `$2:$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);