import re
regex = re.compile(r"^(value)(\d+)", flags=re.MULTILINE)
test_str = ("LeaveThisInArray\n"
"value1\n"
"value2")
subst = "$2:$1"
result = regex.sub(subst, test_str)
if result:
print(result)