import Foundation
let pattern = #"^(value)(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LeaveThisInArray
value1
value2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2:$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)