$re = '/^(value)(\d+)/m';
$str = 'LeaveThisInArray
value1
value2';
$subst = "$2:$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;