package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(value)(\d+)`)
var str = `LeaveThisInArray
value1
value2`
var substitution = "$2:$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}