#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$"
Local $sString = "/repo/requirements/somefile" & @CRLF & _
"/repo/requirements/requirements.txt" & @CRLF & _
"/repo/requirements.txt" & @CRLF & _
"/repo/apps/myapp/requirements/txt" & @CRLF & _
"/repo/apps/myapp/requirements.txt" & @CRLF & _
"/repo/apps/requirements/requirements.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")