re = /^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$/m
str = '/repo/requirements/somefile
/repo/requirements/requirements.txt
/repo/requirements.txt
/repo/apps/myapp/requirements/txt
/repo/apps/myapp/requirements.txt
/repo/apps/requirements/requirements.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end