import re
regex = re.compile(r"^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$", flags=re.MULTILINE)
test_str = ("/repo/requirements/somefile\n"
"/repo/requirements/requirements.txt\n"
"/repo/requirements.txt\n"
"/repo/apps/myapp/requirements/txt\n"
"/repo/apps/myapp/requirements.txt\n"
"/repo/apps/requirements/requirements.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")