$re = '/^\/repo\/requirements\/?.*?$|^\/repo\/requirements\.txt$/m';
$str = '/repo/requirements/somefile
/repo/requirements/requirements.txt
/repo/requirements.txt
/repo/apps/myapp/requirements/txt
/repo/apps/myapp/requirements.txt
/repo/apps/requirements/requirements.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);