import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/repo\\/requirements\\/?.*?$|^\\/repo\\/requirements\\.txt$";
final String string = "/repo/requirements/somefile\n"
+ "/repo/requirements/requirements.txt\n"
+ "/repo/requirements.txt\n"
+ "/repo/apps/myapp/requirements/txt\n"
+ "/repo/apps/myapp/requirements.txt\n"
+ "/repo/apps/requirements/requirements.txt";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}