#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?m)=\s*$"
Local $sString = "$a=5" & @CRLF & _
"$b=""" & @CRLF & _
"$c=" & @CRLF & _
"$d=555" & @CRLF & _
""
Local $sSubst = "=$null"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)