import Foundation
let pattern = #"(?m)=\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
$a=5
$b=""
$c=
$d=555
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"=$null"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)