package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?m)=\s*$`)
var str = `$a=5
$b=""
$c=
$d=555
`
var substitution = "=$null"
fmt.Println(re.ReplaceAllString(str, substitution))
}