import re
regex = re.compile(r"(?m)=\s*$", flags=re.IGNORECASE)
test_str = ("$a=5\n"
"$b=\"\"\n"
"$c=\n"
"$d=555\n")
subst = "=$null"
result = regex.sub(subst, test_str)
if result:
print(result)