// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?m)=\s*$").unwrap();
let string = "$a=5
$b=\"\"
$c=
$d=555
";
let substitution = "=$null";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}