$re = '/(?m)=\s*$/i';
$str = '$a=5
$b=""
$c=
$d=555
';
$subst = "=$null";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;