using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*).{11}\..*$";
string substitution = @"$1";
string input = @"London_7382904821.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}