use strict;
my $str = 'London_7382904821.jpg';
my $regex = qr/^(.*).{11}\..*$/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";