$re = '/^(.*).{11}\..*$/';
$str = 'London_7382904821.jpg';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;