import re
regex = re.compile(r"^(.*).{11}\..*$")
test_str = "London_7382904821.jpg"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)