#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\p{L}\p{Nd}]+)"
Local $sString = "jshdgudgdi^dlnhddhjdhdhdhdkjdh" & @CRLF & _
"&%$#@#$%^&*()" & @CRLF & _
"dndjjskjdlkdjnskjdkjd" & @CRLF & _
"" & @CRLF & _
"nshhd" & @CRLF & _
"" & @CRLF & _
"%#$%01763543892" & @CRLF & _
"" & @CRLF & _
"English:" & @CRLF & _
"" & @CRLF & _
"Finally done, this was the 6th or sixth test." & @CRLF & _
"" & @CRLF & _
"Russian:" & @CRLF & _
"" & @CRLF & _
"Наконец сделано , это было 6-й или шестой тест ." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")