$re = '/([\p{L}\p{Nd}]+)/';
$str = 'jshdgudgdi^dlnhddhjdhdhdhdkjdh
&%$#@#$%^&*()
dndjjskjdlkdjnskjdkjd
nshhd
%#$%01763543892
English:
Finally done, this was the 6th or sixth test.
Russian:
Наконец сделано , это было 6-й или шестой тест .
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);