package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\p{L}\p{Nd}]+)`)
var str = `jshdgudgdi^dlnhddhjdhdhdhdkjdh
&%$#@#$%^&*()
dndjjskjdlkdjnskjdkjd
nshhd
%#$%01763543892
English:
Finally done, this was the 6th or sixth test.
Russian:
Наконец сделано , это было 6-й или шестой тест .
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}