import re
regex = re.compile(r"([\p{L}\p{Nd}]+)")
test_str = ("jshdgudgdi^dlnhddhjdhdhdhdkjdh\n"
"&%$#@#$%^&*()\n"
"dndjjskjdlkdjnskjdkjd\n\n"
"nshhd\n\n"
"%#$%01763543892\n\n"
"English:\n\n"
"Finally done, this was the 6th or sixth test.\n\n"
"Russian:\n\n"
"Наконец сделано , это было 6-й или шестой тест .\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")