using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\p{L}\p{Nd}]+)";
string input = @"jshdgudgdi^dlnhddhjdhdhdhdkjdh
&%$#@#$%^&*()
dndjjskjdlkdjnskjdkjd
nshhd
%#$%01763543892
English:
Finally done, this was the 6th or sixth test.
Russian:
Наконец сделано , это было 6-й или шестой тест .
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}